BF_Intro_Banner_1920_680_Hearing_Aid_RGB

EasyControl-A app compatible devices

EasyControl-A app compatibility

  • mobil_easycontrol_a_compatible

    See the list below to identify the devices which are tested to be compatible with the EasyControl-A app (version 2.0)

    Apple
    • iPhone 5s
    • iPhone 6
    • iPhone 6 Plus
    • iPhone 6s
    • iPhone 6s Plus
    • iPhone 7
    • iPhone 7 Plus
    • iPhone 8
    • iPhone 8 Plus
    • iPhone SE
    • iPhone X
    • iPhone XR
    • iPhone XS
    • iPhone XS Max
    • iPhone 11
    • iPhone 11 Pro
    • iPhone 11 Pro Max
    • iPad Air
    • iPad Air 2
    • iPad Mini 2 Gen
    • iPad Mini 3
    • iPad Mini 4 Gen
    • iPad Pro
    • iPad Pro 9.7"
    • iPad Pro 10.5"
    • iPad Pro 11"
    • iPad Pro 12.9"
    • iPad Pro 12.9" 2 Gen
    • iPad Pro 12.9" 3 Gen
    • iPod Touch 6 Gen
    Google
    • Google Pixel
    • Google Pixel XL
    LG
    • LG G5
    • LG G6
    • LG Nexus 5x
    Samsung
    • Samsung Galaxy A5, A8 (2018)
    • Samsung Galaxy J3 (2016) US Variant
    • Samsung Galaxy J3 (2017), Samsung Galaxy J5 (2017)
    • Samsung Galaxy Note 4
    • Samsung Galaxy S5, S6, S6 Edge, S7, S7 Edge
    • Samsung Galaxy, S8, S9
    Sony
    • Sony Xperia XZ3
    • Sony Xperia XZ
    • Sony Xperia Z5 Premium
    HTC
    • HTC M9
    • HTC U12+
    • Nexus 9
    Motorola
    • Motorola Nexus 6
    Xiaomi
    • Xiaomi Mi Mix3

    If your device is not listed above, it is still possible for it to be compatible with the EasyControl-A app.

    Please note, that the EasyControl-A app is compatible with devices running on the operating system iOS 11.0, watchOS 4.0 or later, or Android 6.0 or later (Android 8.0 or later is strongly recommended). We recommend you to always update your device to the latest version of the operating system.